A+ A A-

Release Notes

 

Version 2.3 (February 2013): Phrasebank, Clipart and Premium 3D Edition added

 

Main additional features:

Phrasebank: When editing text you can now access a rich phrasebank by clicking the phrasebank button. We have added two phrasebanks, the Manchester University phrasebank (http://www.phrasebank.manchster.ac.uk) and another more simple phrase bank. You can drill down into the phrasebank and when you double click onto a phrase the phrase will be copied into the text.

Clipart: We have added a clipart viewer and our own clipart library which contains a lot of useful clipart files. You can also access other clipart files from within the viewer.

3D Mode: The 3D mode is only enabled in the "Premium 3D Edition" of EssayWriter. It allows you to see your map in virtual 3D by tilting it back, thus enabling you to see a much bigger map.

Different Program Editions: We have created a "Standard", "Bibliography" and "Premium 3D" editon of Essay Writer, with different feature set and different prices.

Other changes:

Ideamap editing:

  • When you copy text and paste it on the idea map you now have the choice whether you want this text to be pasted as a "titleless" idea, essentially a paragraph of text. The program will display the topic sentence (i.e. the first sentence) as title.
  • In the idea map settings (Edit->Document Settings...->Ideamap View->Idea Style) you can now select a different method of automatically colouring ideas. Previously you could only have a colour that was dependent on the "level", e.g. "Chapter, Section, ..." of the idea but now you can choose to have all ideas in the same chapter with the same colour. You can combine this with the Text View option of "Colors in Titles->Use Fill Color" and then the program will also show the same colour scheme in the text view, making it easier to see the structure.
  • You can now customise the table of contents (Edit->Document Settings...->Table of Contents). You can select which idea types are included, how "deep" the table of contents needs to be, whether to print the table indented, etc.
  • You can now access the selected dictionaries in the text by clicking the "Dictionary" button and use the dictionary to search for word definitions.
  • In the Premium 3D edition you now have an additional "3D" button which enables the 3D feature. When clicked the map will be tilted automatically so that the entire map is visible and the rotate and tilt thumbwheels allow you to further tilt or rotate the map. While in 3D mode you can edit the map as usual.

Autosave:

We have improved the autosave feature of Essay Writer. In addition to creating a single automatic hidden autosave file which will be overwritten every at a given time interval you can now choose for the program to create a new separate autosave file, thus allowing you to go back in time easily. This can be changed in Tools->Options->General Program->Autosave. Note that you also have to have autosave turned ON in the document settings (File->Properties...->Autosave) for autosave to be enabled.

Bug fixes:

This release contains numerous bug fixes in various areas of the code.

Upgrade Information:

Any 1.0,1.1,1.2,2.0,2.1,2.2 license keys will work with this release. We do recommend that you uninstall Essay Writer first, then remove the "EssayWriter" folder from your computers Program Files folder (or Program Files (x86)) and then download and install this update. There is no need to re-enter the license key or to reactivate.

 

Version 2.2 (October 2012): Paragraph Structure Highlighting and other features added.

 

Main additional feature:

Paragraph Structure Highlighting: When enabled the program changes the background colour of the sentences in each paragraph to "red, amber, green" to indicate topic sentence, main argument and concluding sentence. This helps to improve the clarity and structure of the document.

Other changes:

Ideamap editing:

  • On the idea map, when there are several ideas stacked on top of each other, you can now send an idea to the background.
  • On the idea map you can now double click onto a Table of Contents or Bibliography idea to see the contents.
  • When you select an idea that is connected and click Delete the idea is first disconnected. To delete you must click Delete again.

File Save:

  • You can now save text or map as PDF.
  • You can save the text as outline only.

Text Editing:

  • Text colour can now be accessed from the main toolbar.
  • Text highlighter can now be accessed from the main toolbar.
  • OpenDyslexic font is now part of the installer and can be used throughout the program.
  • Can now change the font throughout the text by using Select All for the text in the main idea and then change the font. An additional animation explains how this works.

Bibliography changes:

  • When you double click on a reference in the references the reference gets opened and you can edit it.
  • List of References now shows references that are used at the top and the unused ones at the bottom.
  • Bibliographic references are no longer shown in text view as this lead to confusion. Instead when you double click on a reference (in text or idea map) the reference is opened and can be changed.
  • Bibliography now supports quotes: If the quote field in the reference is used, and if “use quotes” is turned on in the bibliography style then the program will automatically insert the quote into the text for the very first time the reference is used in the text.
  • Harvard style reference list now uses a hanging indent to visually separate references from each other.

Update check:

The program will now check at regular intervals whether there is a new update available and if so will prompt the user to download the update.

Bug fixes:

This release contains numerous bug fixes in various areas of the code.

Upgrade Information:

Any 1.0,1.1,1.2,2.0,2.1 license keys will work with this release. We do recommend that you uninstall EssayWriter first, then remove the "EssayWriter" folder from your computers Program Files folder (or Program Files (x86)) and then download and install this update. There is no need to re-enter the license key or to reactivate.

 

Version 2.1 (July 2012): Improved Help, Idea Map Editor and Text Editor

 

This version brings the following changes:

Help:

New animations. We have created all new animations which are shorter and which address most aspects of the program. With Help->Animated Help... you can access these animations.

Idea Map Editor:

  • Automatically change the colour of ideas when they are being connected. This is to help the user to see the structure of the document. The colour can be changed again afterwards.
  • Connect ideas by dragging one on top of the other and wait for about half a second while keeping the mouse button pressed. The idea is connected and changes colour and can be dragged away again. This makes it easier than ever to create connections.
  • Split links to make introducing additional headings easier. Just select one or more link at the same level and right-click to select "Insert idea", this will insert the new idea.
  • Hyperlinks can be turned into bibliographic references proper when pasted into the idea map.
  • Hyperlinks and Bibliographic Reference ideas are now showing a little icon indicating their type.

Text Editor:

  • Highlighter pen lets you mark selected text.
  • Direct access for increase / decrease font size from the toolbar.
  • Direct access for the font colour from the toolbar.
  • Links in the text are protected automatically.
  • References to parts of the text can be added very easily with the "Add Reference" button while editing text.
  • Double line spacing is now supported for print preview and printing.

Usability and Look-and-Feel:

  • Toolbars automatically hide and show depending on the context. This creates a much cleaner look and allowed us to avoid having to use a "ribbon".
  • Text labels underneath the toolbar buttons can be turned on (for beginners).
  • The skin can be changed from "Calm Blue" to "Dot Net" depending on the user's preference.

Table of Contents:

  • The table of contents is now a table which contains the word counts.
  • The table of contents can be sorted by clicking on the table header.

Bibliography:

  • Hyperlinks can be turned into bibliographic references proper when pasted into the idea map.
  • Much easier to insert references using the "Add Reference" button while editing text.
  • When the program inserts a reference list or a reference it will use a quick algorithm to make space on the idea map so that the map continues to look tidy.


Bug Fixes:

  • Print idea map now prints the entire map, not just the visible portion.
  • Idea icon grows automatically when the title becomes large.
  • List of References is now cleaned up, no more orphaned colons.
  • More small bugs have been fixed, the list is too exhaustive for these notes.

 

Version 2.0 (January 2012): Bibliography, Word Counts

 

Bibliography Support

EssayWriter now comes with bibliography support. Users can add references to books, articles etc. and the program automatically creates a reference list. The initial release supports an indexed style and Harvard notation style. References can be imported in EndNote™ or RIS format.

Word Counts:

Word count on a per section level. Students can now better balance their essays by using the word counting facility. The program shows how many words are contained in a section and all the sub-sections.

Further Changes:

  • Additional shapes and fill options.
  • Import files directly onto the map. Files can be imported into the map which makes it easier to assemble large essays.
  • "Hide everything else" feature. Users can concentrate on one part of the map.
  • Automatically change the colour of ideas when they are being connected. This is to help the user to see the structure of the document. The colour can be changed again afterwards.
  • Connect ideas by dragging one on top of the other and wait for about half a second while keeping the mouse button pressed. The idea is connected and changes colour and can be dragged away again. This makes it easier than ever to create connections.

Upgrade Information:

Any 1.0,1.1 and 1.2 license keys will work with this release.

 

Version 1.2 (July 2011): Text-to-Speech, Additional Texteditor Features and Templates

 

Text-to-Speech:

EssayWriter now comes with built-in text-to-speech. This can be activated in both the ideamap and the linear text view. The voices that are part of the Windows installer are the standard SAPI5 voices. Any SAPI5 voices can be used by changing the voice in the control panel.

Additional Editing Features in Text View:

The editable text view now allows the user to change text formatting just like in the idea editor that is available as double-click on an idea. This also includes Undo/Redo.

Embedded Images:

Images can now be embedded in the text. Drag & drop of image files on the computer can be used but also cut & paste of images for example from a web-browser window.

Additional "Arts" Dictionary:

The Arts dictionary is very comprehensive and contains many special terms used in arts.

Additional Templates:

A number of templates has been added which all contain tips that guide the user on how to use the templates.

Behaviour Differences:

  • In version 1.1 we introduced a change in how ideas are added. Ideas can only be added if the program is in "Create Ideas Mode", signified by active "Sparks Flying" button. To enter this mode the user had to click this button which led to confusion. From this release on a double-click on the idea map will both create a new idea and also enter the "Create Ideas Mode".
  • Animated scroll and autoarrange. Scrolling and autoarrange are now animated, making it easier to remember the context of the area of the ideamap or text that is being worked on.

Bug Fixes:

  • This version contains a number of bug fixes.
  • Version 1.2.0006: This version fixes a problem with Mac OS 10.7 (Lion) where the license key could not be stored on the computer.

 

Version 1.1 (May 2011): Improved brainstorming mode, Save Settings, Table of Contents Idea

 

Change of how ideas are created:

  • Creating ideas is now only possible if the "create ideas/brainstorm mode" button is pressed.
  • If an idea title is entered and the "Enter" key is pressed, a new idea is created, just like in the previous brainstorm mode.
  • If a new document is created (File->New Blank) the program goes automatically into "create ideas/brainstorm" mode.
    If an existing document is loaded, the program will not be in this mode, thus preventing ideas from being created accidentally.

Additional "Edit->Save Settings" option:

  • Previously, the user had to change the "blank" template to modify the default settings. Now the "Edit->Save Settings" option allows the user to speed up this process by saving the settings in the correct location.
  • If the document already contains ideas these are ignored - the blank template will never contain ideas.

Table of Contents idea:

  • To add a table of contents to a document, right click anywhere on the map and select "Add->Table of Contents". Then connect the new idea to the main idea to add a table of contents to your text document.
  • In the text view the table of contents is a list of links to the various sections, by clicking on a link the text view will scroll to the respective sections.
  • Note that in the "table of contents idea" can be connected to a sub heading, thus creating a table of contents of that section.

Examples for Higher Education:

There are a number of additional examples for higher education, showing how the program can be used.

Smooth scrolling of the map and text view:

  • When clicking on an idea in the map view the text view will automatically scroll to this idea and visa versa.
  • This scrolling is smooth, thus being ideal for people with short term memory problems who find swapping of window contents particularly confusing. As the map and text are scrolling the user can intuitively grasp the correct relationship of ideas.

Smooth scrolling of auto arrange:

  • Auto arrange will move the ideas smoothly to their new location.
  • This helps a user with short term memory problems to retain the relationship between ideas.

Mouse wheel scrolls through the ideas:

When the user uses the mouse wheel in the idea map view the ideas will be selected in the order they will be printed.

MacOS/X version:

EssayWriter is now available for MacOS/X (minimum 10.4)

Bug Fixes:

  • A number of bugs were fixed in this release, serious and minor bugs.
  • Zoom 100% now works
  • Can now double-click on a file in Windows explorer to load files
  • Print preview fixed if no pagesize

Version 1.1.0003 (June 2011)

Minor update, contains a bug fix affecting more complex installation scenarios.

Follow Us

Contact Us


Spark-Space
483 Green Lanes
London, N13 4BS
United Kingdom

Tel. 0203 637 4739

Credentials


Copyright © 2017,
Spark-Space,
All rights reserved.


UK Registered Company
No 07898798

Sitemap

//